rss-atom-bundle’s future

I wasn’t very active on rss-atom-bundle lately but don’t worry, it doesn’t mean I’m not working on it anymore. In fact, I’m writing a new library called feed-io and it will be the new foundation of rss-atom-bundle in the 2.x branch.

What needs to be improved in the master branch
  • the code is not PSR compliant
  • the repository is both a library and a bundle
  • some classes violate the open / close principle. Take the parser, it’s now impossible to extend it.

That’s why I decided to separate the library from the bundle and make the second depends on the first. And in order to preserve backward compatibility, this will happen in a major release.

Incoming releases and branches life cycle

The current 1.x major version will be maintained until the end of the 2.x Symfony version. The next release of rss-atom-bundle will be the 1.5.0 version and will fix the compatibility break issue #55 introduced by Symfony 2.6. I don’t plan to release new features on the 1.x branch, new versions will be released only for bug fixes. Support for this version will end in May 2016.

The new 2.x version will have its own branch and its support will stick to the 3.x version of Symfony. Rss-atom-bundle 2.x will feature :

  • a simpler API built to ease parsing and formatting operations
  • the ability to extend the rules applied to the incoming and outgoing streams
  • medias support
  • CLI command to consume external feeds
  • probably more features

Support for the 3.0 version will end in January 2017.

compatibility
rss-atom-bundle symfony
=< 1.4.x =< 2.5.x
1.5.x =< 2.6.x
2.x >= 3.x

If the project you’re working on depends on the 2.6 version of Symfony, you will need to upgrade rss-atom-bundle to the 1.5 version. If not, I highly recommend to stick with the 1.4 version in order to avoid any compatibility issues.

what’s coming next

1.5.0 version should come this weekend. After that, I will focus on the 2.x branch to release a first beta early next year.